Jump to content
  • 0

Transfers that won’t transfer

Rate this question



I am trying to finish off some MIR cement bubbles and put some transfers in water to loosen them before applying to the model. Nothing happened so I tried some warm water to see if it loosened then from the backing paper but after letting them soak for 20 mins no release. Anyone any ideas?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Check that they are not the ones that you peal off from the backing paper and stick on MIR did some vinyl decals


Anthony you’re just a fountain of knowledge, in all the MIR kits I built I only came across waterslide or rub-on transfers. Don’t remember even seeing vinyl transfers in their catalogue.

Problem solved -thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use